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VBA Course Demo Outline

We won’t build this in its order of execution. We’ll build it as it will probably grow as you apply it at work, an internship, as a research assistant, etc. We’ll start with the sections that are most intuitive to program / record a macro for, and then we’ll build from that for the processes you’ll naturally want to automate next. 

Create a very simple Macro –TempsMacro1_Format.xls
1. Open and delimit the text file Demo(1)040118_04
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Save this file as Demo(Format)Macro.xls
3. Start Recording the Macro

3.1. From the top menu bar: Tools > Macro > Record New Macro

3.2. Enter name: Format_File (or whatever name you want; cannot have spaces)

3.3. With the curser in the Shortcut Key box, press Shift + F, to set Ctrl + Shift + F as the shortcut (not essential, but very convenient for later)

3.4. Click OK, and the box will close leaving another small box in the window with two buttons*. Don’t click those buttons yet.
4. Begin Programming / Recording the Macro
4.1. Right Click on the Row button for Row 1, and select Insert. In this row you will enter the Thermocouple Descriptions.
4.1.1. Enter Descriptions as appropriate to Sensors (whatever you want)
4.2. Right Click again on the Row button for Row 1, and select Format Cells
4.2.1. Under the Alignment Tab, adjust the orientation to 90 deg (and you can do any other formatting that looks convenient)

4.2.2. Click OK

4.3. Insert File Header info

4.3.1. Highlight Rows 1 and 2

4.3.2. Right Click again on one of the highlighted row buttons, and select Insert
4.3.3. Type into these Cells whatever is relevant header info
4.3.4. Make these cells Bold, or whatever other formatting looks good

4.4. Finish Recording the Macro

4.4.1. Find that small box with two buttons

4.4.2. Click the button with the small blue square – This stops recording the macro

4.4.3. Your Macro has been recorded, and can be executed or edited when you want

5. Watch the Macro execute

5.1. Highlight Rows 1 through 3, Right Click, and Delete these Rows. This makes your file look like it did initially. 

5.2. From the top menu bar: Tools > Macro > Macros

5.3. In the Macro Dialog Box Menu, select Format_File, and click Run

5.4. You will see the header you just programmed re-entered on top of the file

5.5. Repeat the previous steps 2 through 4 to execute the macro again, and you’ll see the header again inserted on the top of the file (creating a double stacked header). This isn’t what you want to do, but it shows how the macro executes.

6. Execute the Macro using the Shortcut Key

6.1. Delete the Rows with the Headers you already re-wrote onto the file with the Macro
6.2. Simultaneously press the keys Ctrl + Shift + F

6.3. You will see the Macro execute and re-build the same header you programmed

6.3.1.1. Press the same keys again to double stack the header if you want.

6.4. Now do whatever you need to so your file looks as you want it to, with only the 3 line header.

7. View the Macro Code in the VBA Editor

7.1. From the top menu bar: Tools > Macro > Visual Basic Editor

7.1.1. This opens the VBA Editor in a window next to Excel

7.2. All Macros are stored and executed in Modules. We want to view the module created to store the Format_File Macro we just recorded.
7.2.1. In the Project Tree (found in the upper left frame of the VBA Editor Window), click on the Modules folder, then double click Module1.
7.2.2. This brings up the module we just recorded to be viewed and edited.

7.2.3. There’s a lot of stuff to notice here, that I don’t want to write, so just listen, and here’s a gap to write notes in if you want. 

7.2.4. You can also write your own comments into the code by prefixing the note with ‘
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8. Manually Execute the Macro, to watch what it performs at each command

8.1. With the cursor flashing somewhere within the Sub-Routine you have recorded, press F8
8.2. You will see the top line highlighted in yellow
8.3. Press F8 to step through the Sub-Routine, and watch Excel to see what happens as you execute each step. 

8.4. To run the Macro at normal speed, Pause it, or Stop it, use the blue buttons at the top of the VBA Editor window. 

8.5. To plant Pause Breaks in the code (to run up to that point at full speed), click in the vertical grey space to the left of the module text. A burgundy dot and highlight appears where the code will pause execution. Obviously, this is good for debugging.
9. Edit the Code to change what it performs

10. Clean up the code

10.1. Eliminate window scrolls, unnecessary cell selections, etc.

10.2. Comment the Code so you know what it’s doing 6 months from now when you want to edit it

10.3. Also so others who want to edit it can more readily see what it happening

10.4. It actually feels like quite a compliment to hear somebody say “You comment your code very well.”
Make the Macro an Independent Tool / File

11. Make the Macro independent of the file you recorded it in, so it can be used on other files you pull up.

11.1. Macros are stored in individual workbooks. If you close the workbook that has the Macro in it, you no longer have that Macro available. You have to open the file containing the Macro so you can use it to execute whatever you want on whatever Excel Workbook you choose. Because of this, I usually write the Macros on their own independent file, and title it relative the execution it performs.

12. Our Macro will file will be called TempsMacro1_Format.xls 

12.1. Open a New Excel Workbook

12.2. Save it as TempsMacro1_Format.xls
12.3. Activate the VBA Editor

12.3.1. You will see in the Project Tree that both open workbooks are accessible, each with their own “Microsoft Excel Objects” folders, but only the Demo(1)040118 has a “Modules” folder.
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Insert a “Module” in the new File you created for your Macro: Insert > Module
12.5. Open this new module, and you will see that it is empty.

12.6. Copy the code from the module in the original file, and paste it into the module in the new file.

12.7. You will now need to reconfigure the Shortcut keys in the new workbook to call up this Macro.

12.7.1. From the top menu bar: Tools > Macro > Macros

12.7.2. In the Macro Dialog Box Menu, select Format_File*, and click Options
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*Depending on which file is active when you open the Macro Dialog Box, you will see the other file name prefixing the same module. Select the module in the active workbook, or the workbook you want to modify the Macro Options for.
12.8. With the curser in the Shortcut Key box, press Shift + F, to set Ctrl + Shift + F as the shortcut 

12.9. I like to run the format of the macro in Sheet1 of the file that owns the macro, so it’s easy to see what the macro does, or to associate it with different format files. Then I fill in instructions for the Macro, for the files it’s used for, for shortcut keys, etc.

12.9.1. With TempsMacro1_Format.xls activated, press Ctrl + Shift + F

12.9.2. Now insert whatever notes and other stuff you want, and save the file. 

13. Now try opening some of the sample data files, press Ctrl + Shift + F, and watch it format the files. Don’t save any of the changes to these files!!! Just close them. We’ll want the files in their original format later.

Programming Macros to work with Variable Data Sets
14. Add Calculations to the Macro

14.1. We’re going to add math functions that calculate the average, max, and min running temperature across specific zones, and display these values in their own columns at the end of the recorded data. We will:
14.1.1. 1)Record the macro with using a data file that has not yet been modified with the header
14.1.2. 2) Modify this macro to handle variable amounts of data in the file 

14.1.3. 3) Paste this sub routine in the Macro Project we’re building
14.2. Open the file Demo(1)040118.xls (this is the same as the first data file we used)
14.3. Save this file as Demo(Calc)Macro.xls
14.4. Repeat the same steps defined previously to begin recording a Macro called Data_Calcs 

14.4.1. Name the Macro Data_Calcs (or whatever you want)

14.4.2. Make the Shortcut key Ctrl + Shift + C (again, arbitrarily decided)

14.5. Insert the calculations you want to make

14.5.1. Go to the far right of the worksheet (Column CT)
14.5.2. In Row 1 of the first blank column (CU) enter “Avg TC 5-10”
14.5.3. In the following columns of Row 1, enter

14.5.3.1. Max TC 5-10, Min TC 5-10, Avg TC 33-40, Max TC 33-40, Min TC 33-40 (these are headers in conjunction with the thermocouples you’re calculating) 

14.5.4. In the appropriate columns on Row 2, enter the equations for the groups of thermocouples you want to calculate

14.5.5. Select these, and copy/drag them to the bottom of the data (Row 2162)
14.6. Stop recording the macro by clicking on the small blue square in the box. 

15. Modify the code so it will be applicable to variable data sets

15.1. Open / Activate the VBA Editor and open the module with the code you just recorded

15.2. Clean out the worthless stuff from the code (scrolling, unnecessary selections, etc)
15.3. Comment what is happening with certain blocks of code

15.4. Program Excel to count the total rows and columns with data using the following code:

'**** Code inserted at the beginning for counting rows

'Select CurrentRegion and count rows and columns

   Range("A1").Select

   Selection.CurrentRegion.Select

   numrows = Selection.Rows.Count

‘**Comment out original code for filling cells with inserted formulas

'**** Code modified for counted rows to replace code for filling cells with inserted formulas

'Copy / Drag Formulas to the end of the data

    Range("CU2").Select 'Drags down the first equation alone

    Selection.AutoFill Destination:=Range("CU2:CU" & numrows), _

Type:=xlFillDefault

    Range("CU2:CU" & numrows).Select

    Range("CV2:CZ2").Select 'Drags down the other 5 simultaneously

    Selection.AutoFill Destination:=Range("CV2:CZ" & numrows), _ 

Type:=xlFillDefault

    Range("CV2:CZ" & numrows).Select
16. Erase your previously inserted equations, and try your macro with these variations
16.1. Run it with the original setup

16.2. Delete a significant number of rows from the bottom, and run the macro

16.3. Copy a significant amount of data and paste it in as though it is just more data, and run the macro

17. Move this code to your Macro Project as another sub routine

17.1. Open / Activate your Macro file TempsMacro1_Format.xls  

17.2. Save this under another name as TempsMacro1_Form_Calc.xls  

17.3. Copy the code from the module in Demo(Calc)Macro and paste it above the first Sub Routine in the module in TempsMacro1_Form_Calc.xls 
17.4. Configure the shortcut key for the new Data_Calcs Sub Routine in the new File

17.5. Save your Macro Project, and save and close the data file you used to build this Calc Sub Routine

Programming Graphing
18. Create the File you want to use for building the Data_Graphs Sub Routine

18.1. Open / Activate TempsMacro1_Form_Calc.xls and the data file Demo(1)040118.xls 
18.2. Save the data file as Demo(Graphs)Macro.xls 
18.3. Run the Data_Calcs Macro by pressing Ctrl + Shift + C, or through Tools > Macro > Macros and selecting Data_Calcs and Run

18.4. Run the Format_File Macro by pressing Ctrl + Shift + C, or through Tools > Macro > Macros and selecting Format_File and Run

18.5. Your File is now in the format you will want it to begin recording a macro to build charts
19. Record a Macro to build a chart for a given zone of thermocouples

19.1. Begin recording a macro as instructed previously

19.1.1. Name the Macro Data_Graphs and make the shortcut Ctrl + Shift + G

19.1.2. Build a chart for a block of data (TC 5-10)
19.1.2.1. Make it a Scatter Plot (important if charting with dates)

19.1.2.2. Select the block of x-values (time-stamp) first

19.1.2.3. Keep the data columns to be a single consecutive block (Columns D through H). We’ll do non-consecutive columns later… if we have time.

19.1.2.4. Name it whatever you want, and set whatever other parameters you want

19.1.2.5. Set the chart as a New Sheet

19.1.3. Finish recording the macro by clicking the little blue square on the Macro Box

19.1.4. Your chart builder is recorded

20. Toy around with this a bit

20.1. Press Ctrl + Shift + G, and watch it build a second chart just like the first, this one being named “Chart2” on the tab.
20.2. Open the VBA Editor, and clean up the code

20.3. Copy and modify the code to build another chart for different data

20.3.1. Copy and paste the section of code that builds the chart between the end of the first chart command, and the End Sub command.

20.3.2. Comment the differentiation between the two charts

20.3.3. Find the code that references the columns you recorded your macro to build

20.3.4. Change these column letters / numbers to reference a different set of columns

20.3.5. Change the Title of the Chart to match your new columns

20.3.6. Run the Macro, and this new chart built, along with a third duplicate of the original
21. Make a new Sub Routine (Variable_Graphs) to work for variable data amounts (variable number of rows) by modifying the Data_Graphs code.
21.1. Create a new Sub Routine under the first routine, and call it Variable_Graphs
21.2. Insert the code to count the number of rows on the data sheet at the top of the Sub Routine

21.3. Copy and paste the recorded code for building the first chart into this new sub routine
21.4. Paste the code underneath the row counting code

21.5. Insert “ & numrows & “ in the appropriate sections of the code

21.6. Activate the worksheet with all the data on it

21.7. Configure the Shortcut to be Ctrl + Shift + V

21.8. Execute the macro by pressing Ctrl + Shift + V, or through the menu

21.8.1. This should result in building the same chart you previously had

21.9. Delete or add data as appropriate to test the code for adjusting to the variable data amounts

21.10. Save the File

Prompt the User to Input a Custom Name for the Chart (using the Help files)
22. Prompt the User to input a custom chart title using an input box

22.1. Click on the “Help” Icon, and type “Input Box” (or anything else that seems intuitive) into the window that comes up.
22.1.1. Select “InputBox Function” (or Example, or whatever seems intuitive).

22.1.2. Read what it says about the function, and go to the example that shows how the code is used for different results.

22.2. Go back to the VBA editor, and create a new sub called “Sub InputTest()” to try out the code

22.2.1. Insert the code as shown in the Help file, using your own prompt, Title, and Default entry.

22.2.2. Enter the code for a message box to indicate if the code has been read properly.

ChartTitle = InputBox("Insert the Title for the Chart", _

        "Chart Title Input Box", "East Wall Temperature History")

MsgBox "Chart Title = " & ChartTitle

22.2.3. Press F8 to run through the code and see if it works right.

22.3. Go back to your Variable_Graphs macro code, and insert a couple lines between the code to count the rows, and the code to build the chart.

22.3.1. Copy the code to read in the chart title (without the message box), and paste it into the Variable_Graphs code.

22.3.2. Enter a comment above the code you just pasted in.
22.4. Modify the code in the chart to set the title equal to ChartTitle (no quotes) instead of the “Previous Title” (with quotes) that was recorded into the code.

23. Copy this Sub Routine (Variable_Graphs) into the Module in your Macro File TempsMacro1_Form_Calc.xls
23.1. Reconfigure the shortcut key for Ctrl + Shift + V

24. Save this file as TempsMacro1_Main.xls
25. Close the file Demo(Graphs)Macro.xls
Programming a Main Routine to call Sub Routines from
26. You will now create a Main sub routine that will call these three sub routines in sequence, and give you the option to build a chart, or to not. 
26.1. At the top of Module1 in your independent macro file, create a new sub routine called Main.

26.2. You will enter three commands to call the sub routines
26.2.1. Call the sub routine by simply typing the name of the sub routine

26.2.2. Data_Calcs

26.2.3. Format_File

26.2.4. Variable_Graphs

26.3. Program two message boxes. One to prompt the user before formatting, and the other to ask if the user wants to build a graph or not

26.3.1. Before the Data_Calcs call for the sub routine type the code “MsgBox” followed by whatever prompt you want in “quotes”

MsgBox “The Macro has run calculations” & chr(13) _

& “and will now format the file.”


‘The “_” lets your line carry over in the code


‘The “chr(13)” is the ASCII code for a new line (carriage return)

26.3.2. Before the Variable_Graphs call for the sub routine, you will call up a message box with a Yes and No option.

‘Chart the data by user command

‘Designate the prompt for the message box

    GraphPrompt = "Do you want to build a graph?"

‘Set this variable equal to the response from the user

    BuildGraph = MsgBox(GraphPrompt, vbYesNo)

‘Set Criteria to build graph or not

If BuildGraph = vbYes Then

    Variable_Graphs

End If
26.3.3. Add a final Message Box to indicate the Macro has completed running
26.3.4. Configure the shortcut key for this as Ctrl + Shift + M

26.3.5. Save this File

26.4. Open one of the sample Data Files and save it as some other name.

26.5. Activate the worksheet with the data on it, and run the Macro on this data

Custom Dialog Boxes (Userform) and Creating a New File to compile data into
27. Create two Custom Dialog boxes. One to prompt for a New or Existing Project (or Graphing), and then to prompt for custom file and header information.
27.1. Activate the window with TempsMacro1_Main and save it as TempsMacro2_Main. (This should be the only active Excel window… not that it really matters)

27.2. Activate the VBA Editor, and from the top menu bar select Insert > Userform. You will see the new Userform Template appear in the editor, and the Userform tool box should also appear.

27.2.1. In the Userform Properties list (underneath the Project tree on the left side of the editor), change the Title of the Userform from “Userform1” to “StartPrj_Box” (you cannot have spaces in this). Observe that the name of the Userform in the Project Tree changes.
27.2.2. In the same list, change the Caption to read “Begin Project” (or whatever you want it to be. Observe that the caption at the top of the Userform changes.

27.2.3. From the Userform tool box, select the Label icon, and add a label to the Userform. Write something to the effect of asking the user if they want to create a new project or add data to an existing project. Modify the box so it looks like you want. If you want to modify the text style, you will do this from the properties table.
27.2.4. From the Userform tool box, select the Command Button icon, and place two buttons on the Userform.

27.2.4.1. Change the Names (not caption) to “New_Button”, “Exist_Button”, and “Graph_Button”.
27.2.4.2. Change the Captions of these buttons to “New Project”, “Existing”, and “Graphing”, by clicking on the button text, or from the properties table.
27.2.5. Set the actions performed by clicking the buttons.
27.2.5.1. Double Click the button New Project. This brings up a new window, with the Private Sub routine for clicking that button automatically started.

27.2.5.2. Insert code to hide the box, set the relevant variables, and  /or call the proper subroutines. In our case, we’ll only set variables. 
27.2.5.3.  For each button, set the variable PrjDecision to: 1 for New, 2 for Existing, 3 for Graphing.

27.2.5.4. Create a forth button for canceling the project, and use it to set our variable to 0

27.3. Now modify the code in the Main sub routine to call this box, and act according to the selection. (Warning: We’re going to make a load of significant modifications to the Main subroutine, and create some new sub routines before we’re done here).
27.3.1. Set the Main sub routine to start off by calling up this StartPrj_Box, but typing in StartPrj_Box.Show

27.3.2. Set up a Select Case to decide what to do according to the value that the user sets from the buttons.

'Open box for decision on what you want to do with the macro

StartPrj_Box.Show   'This sets the variable PrjDecision

Select Case PrjDecision

    Case 1  'Case for New Project

    Case 2  'Case for Existing Project

        'We're not going to build this option just yet

    Case 3  'Case for Graphing

    Case Else   'Case for Cancel or error

        Exit Sub    'This exits the sub, ending the program

End Select

27.3.3. Because the Variable we are using is set in another sub routine, we must make this a Public variable. Go to the very top row of the Module, and type in: 


Public PrjDecision As Integer

27.3.4. You will see that Excel recognizes this initialization.

27.4. The case we’re going to deal with first is the New Project case. We will build the code to create a new project, format it, open a data file, process the data… and whatever else we do before we’re done.
27.4.1. Call a new sub routine (that we are going to create), titled NewProject
27.4.1.1. Create this new Sub NewProject just underneath the current Main Sub. In this routine, we will add a new file, and format it for bringing in data.

Sub NewProject()

NewProject_Box.Show   'Open a box to prompt the user for _

 the Project Name

TestName = NewProject_Box.TestName.Text   'Read in the _

Project Name from the Dialog Box

'Create New Workbook to compile file in

Set NewBook = Workbooks.Add

Format_File   'Call up routine to format the new project

MsgBox "Press OK to Browse to Save New Project"

TestPath = Application.GetSaveAsFilename(TestName)  

'Get path to where to save the file

Range("A2").Select

    ActiveCell.FormulaR1C1 = "Path to Project: " & TestPath

ActiveWorkbook.SaveAs Filename:=TestName

End Sub

27.4.1.2. The variables TestName and TestPath will be used elsewhere, so we need to make them Public:

 Public TestName, TestPath As String
27.5. Now we want to create a loop (after the Case Structure) that will allow us to open files, process the data, and compile it to the new project file we have created. 

27.5.1. Erase the code in the Main module that call for Calc_Data and Format File (We now only format the project file. We will call Calc_Data from inside the loop).

27.5.2. Create a Do Loop, that will Loop Until Conclude = True

27.5.2.1. Conclude needs to be declared a Public Boolean (True / False).
27.5.2.2. We also want to initialize Conclude as False before entering the loop.

27.5.3. Record a macro for opening a file, and paste this code inside the loop (You can modify the code to display the previous file compiled in the title bar).
27.5.4. Create a Continue_Box dialog box for the user to set Conclude = True, and finish the loop when finished compiling data.

27.6. Now we will create the Processing routine (ProcessDF) that will be called inside this loop for each file.

27.6.1. Record copying the data from the data file sheet, and pasting it to “Sheet2” in your new project that you opened.

27.6.1.1. modify this code to be compatible with variable data amounts (“using numrows”).

27.7. And now I’m out of time for putting together this outline for this handout. I’m going to finish it, but you’ll have to load it off my web site to get the finished version. www.bryangardner.com
27.8. Take some notes if you want. The code for this ProcessDF, and for the Main will look like this when you’re done.

28. Enjoy

29. Good Luck

30. Feel free to email with questions

31. And Remember… Google Groups is your friend for learning how to do things

***********************************************
Public PrjDecision, numrows As Integer

Public TestName, TestPath As String

Public Conclude As Boolean

***********************************************

Sub Main()

'Open box for initial decision on what you want to do with the macro

StartPrj_Box.Show   'This sets the variable PrjDecision

Select Case PrjDecision

    Case 1  'Case for New Project

        NewProject

    Case 2  'Case for ExistingProject

        'We're not going to build this option just yet

    Case 3  'Case for Graphing

    Case Else   'Case for Cancel or error

        Exit Sub    'This exits the sub, thereby ending the program

End Select

Conclude = False

Do

    AnotherFile = MsgBox("Open the file you want to compile", vbOKCancel)

    If AnotherFile = vbCancel Then Exit Sub 'Be careful with If loops inside Do loops. I the actions are on another line than the If, you need to close it with an End If

    'Open the file to compile

    DataFile = Application.GetOpenFilename("All Files (*.*), *.*", , "Previous File Name:" & DataFile)

    Workbooks.Open Filename:=DataFile

    ProcessDF       'Run Calculations, and paste the data into the main project

    Continue_Box.Show

Loop Until Conclude = True

'***Chart the data by user command

    'Designate the prompt for the message box

        GraphPrompt = "Do you want to build a graph?"

    'Set this variable equal to the response from the user

        BuildGraph = MsgBox(GraphPrompt, vbYesNo)

    'Set Criteria to build graph or not

    If BuildGraph = vbYes Then

        Variable_Graphs

    End If

MsgBox "Macro is finished running."

End Sub

****************************************

Sub ProcessDF()

'Copy over Data to Sheet2 in project workbook

'Select CurrentRegion and count rows

Range("A1").Select

Selection.CurrentRegion.Select

numrows = Selection.Rows.Count

DataFile = Application.ActiveWorkbook.Name  'Read this in for pasting the file name with the data

'Select Data to Copy

Range("A1", "CZ" & numrows).Select

    Selection.Copy

Windows(TestName).Activate

Worksheets("Sheet2").Activate

Range("A1").Select

    ActiveSheet.Paste

    Application.CutCopyMode = False

'Close original data file without saving changes

Windows(2).Close SaveChanges:=False

'Process DF in Project Workbook, Sheet2

Windows(TestName).Activate

Worksheets("Sheet2").Activate

Calc_Data  'Run Calculations on data

'Move Processed Data to Sheet1

    'Copy Calculated Data

Worksheets("Sheet2").Activate

Range("A2:CZ" & numrows).Select

    Selection.Copy

'Find current bottom of the data and paste new data underneath it

Worksheets("Sheet1").Activate

    Range("A1").Select

Selection.CurrentRegion.Select      'Count used Rows and Columns

    numrows = Selection.Rows.Count

    Cells(numrows + 1, 1).Select

    Selection.PasteSpecial Paste:=xlValues, Operation:=xlNone, SkipBlanks:= _

        False, Transpose:=False

    Application.CutCopyMode = False

'Print File Name beside calculated data

Cells(numrows + 1, 105).Select

    Selection.FormulaR1C1 = "Start of Data for: " & DataFile

End Sub
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